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Introduction 

 

For several years, we have been using GeoGebra to develop dynamic classroom 

demonstrations for use in teaching calculus.  We have found GeoGebra to be far 

preferable to other software packages that we had formerly used for this purpose, 

including Derive, The Geometer’s Sketchpad
®

, and the TI-Nspire
TM

 CAS Computer 

Software.  Some of our reasons for liking GeoGebra so much are: 

  

 GeoGebra provides a tight connection between the algebraic and geometric 

representations of mathematical objects.  For example, a function in GeoGebra is 

at once both an algebraic object and a geometric one, and can therefore be 

manipulated in either way.  This connection helps to make GeoGebra an ideal 

environment for exploring concepts of calculus. 

 

 Version 4 of GeoGebra, released in the fall of 2011, includes a number of new 

commands for working with functions.  For instance, the process of illustrating 

and computing a Riemann sum is now a snap, as we will show below. 

 

 GeoGebra 4 has simplified the process of creating both stand-alone Java applets 

and simple web pages with embedded applets.  Since the interactive demos that 

you create with GeoGebra can easily be placed on the web, you can provide your 

students with free, readily available access to those demos for continued 

exploration outside of class. 

 

 GeoGebra is free!  Distributed by its international development team under the 

GNU General Public License, GeoGebra will cost you nothing to use or even to 

install on every computer on campus!  But remember that your students will not 

need GeoGebra to interact with the GeoGebra applets you create; they will need 

only the most common of today’s computer tools: an internet connection and 

Java.  To get started with GeoGebra, visit the GeoGebra web site, at 

http://www.geogebra.org. 

 

In this paper we give step-by-step instructions for creating several interactive calculus 

demos.  We hope these inspire you to create some of your own. 
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Riemann Sums 

 

Follow these directions to create a GeoGebra applet to demonstrate the convergence of 

Riemann sums to a definite integral. 

 

 Create a function, like    1
2

2
2 1f x x   , in the input bar. 

 Define numbers a and b by typing 1a    and 0b   in the input bar.  Later we 

will insert input boxes to allow the user to change these values. 

 Create corresponding points A and B on the x-axis by typing  ,0A a  and 

 ,0B b  in the input bar.  Right-click on the point A and open the Object 

Properties box for this point; add the caption “a” and change the Show Label 

option to “Caption.”  Similarly, change the caption for point B. 

 

 Use the “Slider” tool  to create a slider named n for the number of rect-

angles that will be drawn.  The slider type can be either “Number” or “Integer.”  

Either way, the minimum should be 1, the maximum should be a relatively large 

number (like 200), and the increment should be 1.  In the “slider” tab of the dialog 

box, set the width of the slider, and uncheck the “Fixed” property so that you can 

reposition the slider later.  You can change all of these settings later in the Object 

Properties box for the slider, if you decide you need to.   

 

 Create a slider named  position  which specifies the relative location of the sample 

points in each subinterval.  Use a minimum value of 0 and a maximum value of 1, 

and an appropriate increment value, like 0.1. 

 

 Use the “RectangleSum” command to create the Riemann Sum and corresponding 

picture, by typing this expression in the input bar: 

RiemannSum = RectangleSum[ f, a, b, n, position] 

 

 Use the Insert Text tool  to create a text object that explains the use of the 

position slider:  “Use this slider to set the relative position of the sample points in 

each subinterval.”  Create a text object that explains the use of the n slider:  “Use 

this slider to set the number of subintervals.” 

 

 Click the “Insert Input Box” tool  to create input boxes for the values of a 

and b, and the function  f.  Include the appropriate caption, and choose the linked 

object from the drop down menu.  After creating the objects, right click on their 

captions, open the Object Properties, and use the “Style” tab to set an appropriate 

length for the input box.  A length of 2 or 3 should be sufficient for a and b. 
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 Create a text object to show the Riemann sum.  In the text creation dialog box, 

type the phrase “Riemann sum =” (no quote marks), and then select the 

RiemannSum variable from the “Objects” drop down menu.  This creates a field 

that holds the value of the RiemannSum variable. 

 Use the special action tool  to create a check box to show the value of the 

Riemann sum.  Select the Riemann sum text object from the drop down menu. 

 

 Format colors, font sizes, line thicknesses and point sizes as desired, and move the 

sliders, input boxes, and text fields to appropriate locations.  Determine which 

objects’ labels to show.  (In the worksheet below, we’ve chosen not to show the 

label for the position slider.) 

 

 Set a, b, n, and position to the values you would like the user to see on first 

opening the worksheet or applet.  Adjust the toolbar and window size.  Then save 

the worksheet and export it as a webpage.  (See the section below on Creating 

Applets for the Web.) 

 

 
 

Figure 1:  The finished Riemann sum worksheet 

 

 

Optional Enhancement for Riemann Sums 
 

We can make a more obvious connection between the value of the position variable and 

the special sample points that calculus textbooks usually direct students to use.  Create 
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three separate text objects, with the phrases “left endpoints,” “right endpoints,” and 

“midpoints.”  Drag these to their relative locations under the position slider.  Then in the 

Object Properties for each text object, select the “Advanced” tab and enter values in the 

“Conditions to show” field:  0position   for left endpoints, 0.5position   for right 

endpoints, and 1position   for left endpoints.  (Of course, you need to make sure that the 

increment for position allows 0.5position   to occur.)   

 

 

Graph of the Derivative Function 

 

Follow these directions to create a GeoGebra applet to sketch the graph of  f x  from a 

given graph of  f x . 

 

 In the Options menu, turn “Point Capturing” off. 

 Create a function, like   31
4

2 1f x xx   , in the input bar. 

 Use the point tool  to create a point on the x-axis.  In the object properties 

for this point, change the caption to x, and change the “Show Label” option to 

“caption.” 

 Create the corresponding point P on the graph of  f x  by typing 

     ,P x A f x A  in the input bar.  Use the special line tool  for 

tangents to construct the tangent line to the graph of  f x  at P.   

 Use the measurement tool  for slope to measure the slope of the tangent 

line.  The default name for this variable should be m.  If it’s not, use the object 

properties for the slope and change the name to m.  Right-click on the slope, and 

deselect “Show Object.” 

 

 Plot the corresponding point Q on the graph of  f x  by typing   ,Q x A m  in 

the input bar.  As you use the mouse to drag the point labeled x, notice that the 

point P moves along the graph of  f x , and the point Q moves along the graph 

of  f x . 

 Right-click on the point Q to turn traces on (or off).  To erase existing traces, use 

the View menu to refresh the view. 

 Use the text tool  to insert a text object showing the coordinates of P.  In 

the text creation dialog box, type the phrase “P =” (no quote marks), and then 

select P from the “Objects” drop down menu.  This creates a field that holds the 

value of the variable P. 
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 Similarly, create text objects for the slope of  f x  and the coordinates of Q. 

 Use the special action tool  to create a check box to show the tangent line 

at P.  Select the tangent line from the drop down menu.  

 

 Similarly, create check boxes to show:  

o the slope of the tangent line – select the text object with the slope from the 

drop down menu. 

o the point Q and its coordinates – select both Q and the text object with its 

coordinates from the drop down menu. 

 Click the special action tool  to create an input box for the function f.  Type 

“  f x ” as the caption and choose  f x  from the “Linked Object” drop down 

menu.  After creating the input box, right click on its caption, open the Object 

Properties, and use the “Style” tab to set an appropriate length for the input box.  

 

 Format colors, font sizes, line thicknesses and point sizes as desired, and move the 

input box, check boxes, and text fields to appropriate locations.   

 

 Move the point labeled x, turn the check boxes on or off, and turn the traces for Q 

on or off, so that the worksheet appears as you want the user to first view it.  

Adjust the toolbar and window size.  Then save the worksheet and export it as a 

webpage.  (See the section below on Creating Applets for the Web.) 

 

 

 
 

Figure 2:  Completed worksheet for the graph of the derivative 
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Optional Enhancement for Graph of the Derivative Function 

 

Type    Derivativeg x f  in the input bar to get the graph of  f x .  Change this 

graph to a different color, and insert a check box to show/hide it.  This allows the user to 

see the point Q moving along the graph of  f x . 

 

 

Creating a New Tool:  Newton’s Method 
 

You can create a new tool in GeoGebra to iterate the steps of a construction.  We 

demonstrate this via Newton’s Method. 

 

 In the Options menu, turn “Point Capturing” off. 

 

 Create a function, like   31
4

1f x x x   in the input bar. 

 Use the point tool  to create a point A on the x-axis.   

 Create the corresponding point P on the graph of  f x  by typing 

     ,P x A f x A  in the input bar.   

 Use the special line tool  for tangents to construct the tangent line to the 

graph of  f x  at P.   

 Use the point tool for intersections  to construct the intersection of the 

tangent line and the x-axis.   

 From the Tools menu, select “Create New Tool.” 

 In the dialog box, under “Output Objects”, use the drop down list to select the 

tangent line, the point P, and the x-intercept.  Then click “Next.” 

 

 
 

Figure 3:  Create New Tool - Select the Output Objects 

34



 

 The function  f  should automatically appear in the “Input Objects” tab.  Select the 

initial estimate A from the drop down list.  Then click “Next.” 

 

 
 

Figure 4:  Create New Tool - Select the Input Objects 

 

 In the “Name & Icon” tab, type the name of the tool:  “Newton’s Method.”  The 

command name (for use if you type the command in the input bar) appears 

automatically.  Change this if you like.  Add tool help directions, and change the 

icon if you have an appropriate image file stored on your computer.  Make sure 

the “Show in Toolbar” box is checked.  Then click “Finish.” 

 

 Practice using your new Newton’s Method tool. 

 

 Format colors, font sizes, line thicknesses and point sizes as desired.  Delete all of 

the tangent lines and points on the graph, leaving just the graph of the function 

and the initial point A.  Adjust the toolbar and window size.  Then save the 

worksheet and export it as a web page.  (See the section below on Creating 

Applets for the Web.) 

 

 

Optional Enhancement for Newton’s Method 
 

Click the special action tool  to create an input box for the function  f.  Type the 

caption “  f x ” and choose  f x  from the “Linked Object” drop down menu.  After 

creating the input box, right click on the caption, open the Object Properties, and use the 

“Style” tab to set an appropriate length for the input box.   
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Figure 5:  Finished Newton’s method worksheet 

 

 

Creating Applets for the Web 

 

Before saving a GeoGebra worksheet as a web page, adjust the format to what you want 

the users to see.  For example, you might want to use the View menu to hide the algebra 

portion of the worksheet.  Use the Tools menu to customize the toolbar, giving users only 

the tools they need for that particular activity.  Finally, resize the window to the desired 

size of the applet that will be embedded in the web page.  If you create a web page using 

a full screen GeoGebra worksheet, students will have to scroll to see parts of it in the 

resulting web page. 

 

Once the worksheet has the desired format, follow these steps to create a web page 

containing the GeoGebra worksheet as an applet. 
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 Choose “Export ... Dynamic Worksheet as Webpage” from the File menu.  Click 

the “Export as Webpage” tab in the resulting dialog box. 

 Type a title for the web page in the Title field, and type directions and 

explanations in the fields for Text above and below the construction.   

 Click the “Advanced” tab (below the author information field), and select the 

desired features under Functionality and User Interface. 

 Make sure that “Include jar files” is unselected. 

 Click “Export.” 

 Use an html editor if necessary to format and/or change the text on the web page. 

 Put the resulting web page on your web server or somewhere else where students 

can access it.  We frequently embed these pages directly in Blackboard; 

presumably you can embed pages in your course management system as well. 

 

 

Conclusion 

 

As the examples in this paper show, the ease and versatility of GeoGebra make it an ideal 

tool for creating dynamic worksheets for both classroom demonstration and student 

exploration.  GeoGebra’s close connection between the algebraic and geometric 

representations of functions helps students visualize concepts from calculus from 

multiple perspectives.  Moreover, since it is extremely simple to make dynamic Java 

applets available on the web with GeoGebra, you can easily make it possible for your 

students to continue interacting with mathematical concepts beyond the classroom.   

 

For additional examples of creating calculus demos using GeoGebra we invite you to 

visit our web site, at http://www.jcu.edu/math/ICTCM2012, and/or see the paper listed in 

the reference section below. 

 

 

Reference 

 

[1] D’Ambrosia, Barbara K. and Carl R. Spitznagel. “GeoGebra: Dynamic Mathematics 

Made Easy.”  Proceedings of the 22
nd 

Annual International Conference on Technology in 

Collegiate Mathematics (2011). 

37

http://www.jcu.edu/math/ICTCM2012



